Workers Downtime

Major incident NPS.Today SMS Service NPS.Today Mail Service
2025-02-11 09:00 UTC · 7 minutes

Updates

Resolved

This is now resolved

February 11, 2025 · 09:07 UTC
Issue

We are experiencing some downtime on our workers. This will affect adding campaignmembers, notifications, etc.

February 11, 2025 · 09:00 UTC

← Back