Platform status
Subscribe
to updates
Test incident
Minor incident
nps.today API
2025-05-20 09:33 UTC
· 4 minutes
Updates
Resolved
This has been resolved
May 20, 2025 · 09:37 UTC
Issue
Only a test, please disregard!
May 20, 2025 · 09:33 UTC
← Back