Slow performance

Minor incident nps.today API
2025-09-10 11:45 UTC · 1 hour, 35 minutes

Updates

Resolved

Issue is resolved

September 10, 2025 · 12:00 UTC
Monitoring

We are experiencing slow performance on our platform, we are investigating

September 10, 2025 · 11:51 UTC

← Back